massExpConsole – Collection of Tools and Exploits with a CLI UI

Collection of Tools and Exploits with a CLI UIWhat does it do?an easy-to-use user interface (cli)execute any adapted exploit with process-level concurrencycrawler for baidu and zoomeyea simple webshell managersome built-in exploits (automated)more to come…RequirementsGNU/Linux or MacOS, WSL (Windows Subsystem Linux), fully tested under Kali Linux (Rolling, 2017), Ubuntu Linux (16.04 LTS) and Fedora 25 (it will work on other distros too as long as you have dealt with all deps)proxychains4 (in $PATH), used by exploiter, requires a working socks5 proxy (you can modify its config in mec.py)Java is required when using Java deserialization exploits, you might want to install openjdk-8-jre if you haven’t installed it yetpython packages (not complete, as some third-party scripts might need other deps as well): requestsbs4beautifulsoup4html5libdocoptpip3 install on the gonote that you have to install all the deps of your exploits or tools as wellUsagejust run mec.py, if it complains about missing modules, install themif you want to add your own exploit script (or binary file, whatever): cd exploits, mkdir your exploit should take the last argument passed to it as its target, dig into mec.py to know morechmod 755 <exploitBin> to make sure it can be executed by current useruse attack command then m to select your custom exploittype help in the console to see all available featuresDownload massExpConsole

Link: http://feedproxy.google.com/~r/PentestTools/~3/n_22lP9qR0U/massexpconsole-collection-of-tools-and.html